PDA

View Full Version : pedal "clicking"



newbeat
03-08-2003, 04:44 PM
I have a yamaha double chain double pedal (good pedal btw), and the right pedal lately has been starting to have a sort of "bump" when I push it down. When I press it down, you can hear a click as it goes back and forth over a certain point, and you can feel it bump. It's not in the footboard hinge, I've figured that much out, but I don't know where this bump is coming from...hope this made sense, any help would be appreciated, thanks.

Zero
03-08-2003, 10:53 PM
Do you play with your springs really loose? If so it may be the footboard hitting the screw for the clamping of the pedal onto the BD. rim.(sorry I do not know the proper terminology for that part.)

newbeat
03-08-2003, 11:21 PM
Thanks for the reply, but it isn't the pedal hitting anything- the pedal doesn't stop, it just goes over a "lump"...just imagine pushing it down with your foot and halfway there you hear and feel a little pop in the pedal, same thing on the way back up.

Zero
03-08-2003, 11:38 PM
Check the cam that the chain sits on for any foreign objects.

Full Collapse
03-09-2003, 12:14 AM
Happened to my single DW pedal once. All you gotta do is fool around with all the Drum key screws on it a bit. It will eventually stop. I can't remember exactly what was wrong but that should work.

Bostic
03-09-2003, 03:28 AM
That also happened with my old DW5000 pedal as well. I looked at it closely while pushing down the footboard with my hand, it would click ever so slightly on one of the teeth on the cam. I cleaned the cam really well and put a dash of tri-flow bike chain lubricant on the chain. I also made sure the chain was dead even with the cam so like mentioned above check that out with the adjustments of your pedal.

newbeat
03-09-2003, 08:34 AM
Alright, thanks everyone, I'll mess around with it and see what I can do.

rbailey
03-09-2003, 09:23 AM
Why not try taking the chain from your left pedal and putting it on the right. This would at least tell you if it is the chain that is causing your problem. And, that would be easy to replace. It may just be a stiff link in the chain or the link may be bent.

Hutch
03-09-2003, 01:47 PM
I've had this happen before, never with yamaha, but i found that on one of my single pedals the bearing had streched the metal in the post and the clicking was coming from the bearing moving back and forth in it. Make sure the bolt at the end is tight that might help, new bearings might help too.

Hutch